Avatar

Please consider registering
guest

Register | Lost password?
Advanced Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters




sp_Feed Topic RSS sp_Print sp_TopicIcon
Model 75 ejecting problem
September 12, 2021
2:37 pm
Avatar
WACA Guest
Forum Posts: 4
Member Since:
September 12, 2021
sp_UserOfflineSmall Offline

My rifle extracts the empty shell with out a problem, the problem is the empty shell won’t eject out of the receiver.  It lays on top of the next round to be chambered.  

I would appreciate any advice.

September 12, 2021
5:18 pm
Avatar
Northern edge of the D/FW Metromess
WACA Member
Forum Posts: 3286
Member Since:
November 7, 2015
sp_UserOfflineSmall Offline

May not be a mechanical issue, try working the bolt a bit work briskly. I’ve had the same issue when moving the bolt too slowly.

 

Mike

Life Member TSRA, Endowment Member NRA
BBHC Member, TGCA Member
Smokeless powder is a passing fad! -Steve Garbe
I hate rude behavior in a man. I won't tolerate it. -Woodrow F. Call, Lonesome Dove
Some of my favorite recipes start out with a handful of depleted counterbalance devices.-TXGunNut
Presbyopia be damned, I'm going to shoot this thing! -TXGunNut
September 12, 2021
8:04 pm
Avatar
WACA Guest
Forum Posts: 4
Member Since:
September 12, 2021
sp_UserOfflineSmall Offline

I have tried a heavier hand but doesn’t seem to help.  Also, the fired shells will eject out the left side of the receiver sometimes??????    Can it be an ejector problem.

Thank you, I appreciate your response.

September 15, 2021
2:17 am
Avatar
WACA Member
Forum Posts: 20
Member Since:
November 12, 2018
sp_UserOfflineSmall Offline

Check to make sure the ejector (the half moon piece toward the rear of the breech) is not installed backward.

There is a channel in the middle of it, and at the front right side of the channel a corner should be shaved off.

If you don’t see it, the ejector is likely on backward.

Here’s a photo:

https://jackfirstinc.com/winchester-69a-75-ejector-80-2775?search=winchester%2075%20ejector

September 26, 2021
1:52 am
Avatar
WACA Guest
Forum Posts: 4
Member Since:
September 12, 2021
sp_UserOfflineSmall Offline

Thank you for your response.  I have polished the left extractor so it releases the shell better.  That helped a little.  When the magazine is empty the shell ejects properly.  The magazine has a lot of play.  Is this correct?  Or is that my problem?  It seems if there is a round in the magazine it retards the ejected shell.  Any more ideas?

September 26, 2021
2:45 am
Avatar
Northern edge of the D/FW Metromess
WACA Member
Forum Posts: 3286
Member Since:
November 7, 2015
sp_UserOfflineSmall Offline

With feeding issues the easy answer is to try another magazine. Ejection? Maybe. Factory or aftermarket mag? Never had an issue with a factory magazine but it’s possible. 

 

Mike

Life Member TSRA, Endowment Member NRA
BBHC Member, TGCA Member
Smokeless powder is a passing fad! -Steve Garbe
I hate rude behavior in a man. I won't tolerate it. -Woodrow F. Call, Lonesome Dove
Some of my favorite recipes start out with a handful of depleted counterbalance devices.-TXGunNut
Presbyopia be damned, I'm going to shoot this thing! -TXGunNut
Forum Timezone: UTC 0

Most Users Ever Online: 628

Currently Online: tsillik, Manuel, foxfire, .32WCF
55 Guest(s)

Currently Browsing this Page:
2 Guest(s)


Forum Stats:

Groups: 1

Forums: 16

Topics: 9067

Posts: 78111


Member Stats:

Guest Posters: 1219

Members: 10568

Moderators: 4

Admins: 3


Top Posters:

1873man: 4901

TXGunNut: 3286

clarence: 3153

Chuck: 2730

twobit: 2697

steve004: 2367

Maverick: 1777

Big Larry: 1629

JWA: 1605

RickC: 1340