Avatar
Please consider registering
Guest
Search
Forum Scope




Match



Forum Options



Minimum search word length is 3 characters - maximum search word length is 84 characters
Register Lost password?
sp_Feed sp_PrintTopic sp_TopicIcon
Model 74 documentation
sp_NewTopic Add Topic
Avatar
SO. Oregon
Member
WACA Member
Forum Posts: 683
Member Since:
June 5, 2015
sp_UserOfflineSmall Offline
21
October 19, 2020 - 7:40 pm
sp_Permalink sp_Print sp_QuotePost
sp_ReportPost

Thanks Jeff.

Vince
Southern Oregon
NRA member
Fraternal Order of Eagles

 “There is but one answer to be made to the dynamite bomb and that can best be made by the Winchester rifle.”

Teddy Roosevelt 

4029-1.jpg

Avatar
Location: 32000' +
Member
WACA Member
Forum Posts: 1827
Member Since:
July 17, 2012
sp_UserOfflineSmall Offline
22
October 20, 2020 - 1:07 am
sp_Permalink sp_Print sp_QuotePost
sp_ReportPost

Vince said
Thanks Jeff.  

Just joggin’ your memory Laugh

WACA Life Member #6284 - Specializing in Pre-64 Winchester .22 Rimfire

http://rimfirepublications.com/  

Avatar
Harold Collins
Guest
Guests
23
July 21, 2022 - 4:27 am
sp_Permalink sp_Print sp_QuotePost
sp_ReportPost

My Dad gave me my Model 74 when I was a kid. I used it for many years and as time went by I obtained other 22 rifles and the Model 74 was put away. So I did not use it from 1982 till last week. And just like one of the others who posted it would not feed. So I took it home removed the bolt & gave it a thorough cleaning. When I went back out to the range it still had a feeding problem. I recleaned it & put special emphasis on cleaning the ramp. Then I had another session with it and it still had a feeding problem. While I was loading the gun I noticed that the new cartridges didn’t just slide easy into the feed tube like they used to years ago. So I cleaned the tube really well & the inside of the rod that pushes the ammo into the ramp. Finally it feeds perfectly just like it did back in the 60’s & 70’s! It took me a bit to catch on to the feed tube & feed tube rod being the culprit. I am really happy that it is functioning like it should!

Forum Timezone: UTC 0
Most Users Ever Online: 628
Currently Online: .32WCF
Guest(s) 52
Currently Browsing this Page:
1 Guest(s)
Top Posters:
1873man: 5178
clarence: 4316
TXGunNut: 3895
Chuck: 3514
steve004: 3108
twobit: 2843
Maverick: 2017
JWA: 1827
Big Larry: 1765
Forum Stats:
Groups: 1
Forums: 16
Topics: 10417
Posts: 89781

 

Member Stats:
Guest Posters: 1431
Members: 11507
Moderators: 3
Admins: 3
Navigation