Avatar

Please consider registering
guest

Register | Lost password?
Advanced Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters




sp_Feed Topic RSS sp_Print sp_TopicIcon
What´s wrong with my 61?
October 25, 2016
6:00 pm
Avatar
WACA Member
Forum Posts: 65
Member Since:
April 5, 2010
sp_UserOfflineSmall Offline

Hello,

wondering what´s not correct with my model 61 pump? The action is sticky, especially when the slide handle is pulled far back. I need considerable force to push the handle back again, it feels like the slide bar stucks on somehow? Also, when cocked, the handle moves still about half an inch forwards even if the bolt is cammed on “locked” position? Is this normal? So, the gun is cocked but slide handle can be moved that half an inch back- and forwards. Something to do with that sticky feeling when slide& bolt are pulled back?

I disassembled the gun, took the bolt out and examined the inner parts. No signs of excessive wear and tear, everything seems to be okay. But still I feel something is not right: I can shoot my model 62 and 1890 much faster, same with Browning Trombone: all these are approximately twice as fast to shoot than the 61. That can´t be normal, or what? Please help if you have some ideas.Frown

Forum Timezone: UTC 0

Most Users Ever Online: 628

Currently Online: JWA, Kirk Durston, Tedk, Bill Hanzel
63 Guest(s)

Currently Browsing this Page:
1 Guest(s)


Forum Stats:

Groups: 1

Forums: 16

Topics: 9296

Posts: 80191


Member Stats:

Guest Posters: 1257

Members: 10721

Moderators: 4

Admins: 3


Top Posters:

1873man: 4966

TXGunNut: 3431

clarence: 3352

Chuck: 2919

twobit: 2728

steve004: 2502

Maverick: 1842

Big Larry: 1632

JWA: 1616

RickC: 1461