Avatar
Search
Forum Scope




Match



Forum Options



Minimum search word length is 3 characters - maximum search word length is 84 characters
Lost password?
sp_Feed sp_PrintTopic sp_TopicIcon
Model 62 failure to feed
sp_NewTopic Add Topic
Avatar
New Member
WACA Member
Forum Posts: 1
Member Since:
February 24, 2024
sp_UserOfflineSmall Offline
1
March 19, 2024 - 6:37 pm
sp_Permalink sp_Print sp_QuotePost

I have a 1936 production Model 62 in S, L, or LR. I purchased it as a match for another identical one and have refurbished both for grandsons. One feeds and shoots flawlessly while the other may or may not pick up a cartridge from the magazine tube. I have throughly cleaned it and have replaced the carrier spring and checked for any burrs that could affect pickup. I also have replaced the magazine tube spring with the appropriate length item but this has not changed the intermittent feeding. What am I missing?

Avatar
LI NY
Member
WACA Member
Forum Posts: 120
Member Since:
August 14, 2021
sp_UserOfflineSmall Offline
2
March 22, 2024 - 6:03 pm
sp_Permalink sp_Print sp_QuotePost

Hard to say without seeing it, but I would look closely while cycling the action, you should be able to see the issue, or have someone film it under good light while you cycle the action. Don’t shoot your eye out. Other then that bring it to a competent smith.

Forum Timezone: UTC 0
Most Users Ever Online: 778
Currently Browsing this Page:
1 Guest(s)
Top Posters:
clarence: 6354
TXGunNut: 5015
Chuck: 4596
1873man: 4317
steve004: 4244
Big Larry: 2338
twobit: 2293
mrcvs: 1723
TR: 1722
Forum Stats:
Groups: 1
Forums: 17
Topics: 12736
Posts: 110930

 

Member Stats:
Guest Posters: 1758
Members: 8842
Moderators: 4
Admins: 3
Navigation