Avatar

Please consider registering
guest

Register | Lost password?
Advanced Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters




sp_Feed Topic RSS sp_Print sp_TopicIcon
1886 carrier problem
January 11, 2014
2:02 pm
Avatar
WACA Member
Forum Posts: 117
Member Since:
December 12, 2012
sp_UserOfflineSmall Offline

I recently bought an 1886 in .33 WCF.(124103) I took it out to shoot this morning and noticed the carrier drops slightly when moving the bolt forward, resulting in the bullet not loading into the chamber. Would this be a weak/broken carrier spring? Or something else?

January 11, 2014
7:18 pm
Avatar
WACA Member
Forum Posts: 141
Member Since:
January 24, 2013
sp_UserOfflineSmall Offline

Weak/broken spring check the screw it might be loose. Also a worn notch in the carrier

January 11, 2014
7:50 pm
Avatar
WACA Member
Forum Posts: 117
Member Since:
December 12, 2012
sp_UserOfflineSmall Offline

If the carrier is worn, is this something that could be repaired or would it have to be replaced? Thanks for your reply mike!

January 12, 2014
4:53 am
Avatar
WACA Member
Forum Posts: 117
Member Since:
December 12, 2012
sp_UserOfflineSmall Offline

Mike Hunter said
Weak/broken spring check the screw it might be loose. Also a worn notch in the carrier

mike. I took the stock off tightened the spring screw and it works perfect! Thanks again!

Forum Timezone: UTC 0

Most Users Ever Online: 628

Currently Online: dane62, RickC
31 Guest(s)

Currently Browsing this Page:
1 Guest(s)


Forum Stats:

Groups: 1

Forums: 16

Topics: 9177

Posts: 79013


Member Stats:

Guest Posters: 1237

Members: 10629

Moderators: 4

Admins: 3


Top Posters:

1873man: 4927

TXGunNut: 3359

clarence: 3229

Chuck: 2809

twobit: 2717

steve004: 2424

Maverick: 1796

Big Larry: 1631

JWA: 1605

RickC: 1401